Benjamins Blog

Benjamin Wegner über Weisheiten, SharePoint und IT Zeugs

Benjamins Blog header image 2

Probleme mit Zielgruppen

Juli 13th, 2008 ·

Bei einem Kunden hatte ich kürzlich das Problem, dass die Zielgruppen/ Audiences nicht mehr erstellt wurden. Die Auswirkungen stellten sich so dar, dass im Active Directory neue Gruppen erstellt wurden, diese aber in die Zielgruppenadressierung eines Webparts nicht ausgewählt werden konnten. Es standen lediglich alte Gruppen zur Verfügung.


Nach einigen Recherchen stellte ich folgendes fest:



  • Es werden nur die Gruppen geladen, die auch User enthalten
  • Änderungen oder Umzüge der Gruppen werden nicht berücksichtigt (vermutlich ein Designfehler/ Bug)
  • In der Tabelle MemberGroup der SSP Datenbank stehen alle importierten Gruppen mit letzten Sync Datum
  • Sync findet beim Profile Import im SSP statt

 


Nach näherer Analyse des Problems am System stellte sich heraus, dass der Sync nicht durchlief, da in der Membergroup Tabelle keine neuen Daten/ Aktualisierungen zu sehen waren. Selbst beim manuellen Starten des Profil Imports fand keine Veränderung statt.


Aber es trat eine Exception im Log, bzw. im Eventlog des Systems auf:


[…] Retrieving the COM class factory for component with CLSID {3D42CCB1-4665-4620-92A3-478F47389230} failed due to the following error: 80070005. […]


Nach einiger Suche bin ich auf diesen Blogeintrag gestoßen, nachdem nach der Installation von SP1 ein Rechteproblem auftritt.


Zur Behebung des Problems wurden folgende Schritte durchgeführt, was auch schließlich zum Erfolg führte:


stsadm -o osearch -action start

After you run this command you can browse to the permissions of the the OSearch DCOM application and confirm that the sharepoint service accounts and the WSS_ADMIN_WPG and WSS_WPG groups have been granted local launch and local activation permissions.

Das Problem tritt aber scheinbar nur auf, wenn das SP1 nachträglich installiert wird. Bei Slipstream Installation von MOSS mit SP1 gabs keine Probleme.

Tags: Allgemein